Required updates for theme components

Some of the technology that powers Discourse is changing. Discourse is moving from Ember 3 to Ember 5 and as a consequence some themes, theme components and plugins need to be updated to work with this newer version of Ember.

In the first week of February 2024 we have updated your forum to Discourse 3.2 but we have left it on Ember 3 for now. If there are components of your forum that need an update, you will see a big red “admin notice” in the top of your screen. Don’t worry – it’s visible for administrators only, your users won’t see this.

You will need to contact the author of your theme and ask them to make the required updates.

We will be moving to Ember 5 eventually, starting in the first week of March 2024. Any theme components that are still an issue by then will be disabled before we perform the update.

If you have any more questions, don’t hesitate to reach out to us.

More technical background can be found on Discourse Meta in the topic “Preparing for Discourse‚Äôs upgrade to Ember 5“.